"Disconnect: Buffer Overflow in Net Message"

Discussion in 'Team Fortress 2' started by Woomy, May 1, 2020.

  1. Woomy

    Woomy Active Forum Member

    Joined:
    Sep 21, 2017
    Messages:
    64
    Likes Received:
    117
    Hey gang.

    In recent weeks I've been having an issue crop up when playing on the {FITH} TF2 server. Sometimes when a lot is happening in the game I lose my connection with the aforementioned message.

    Seems to occur when the server is full and a lot of people are talking at once or a lot happens on screen at the same time, usually the former.

    Has anyone else encountered this problem? Anything I can do on my end to fix this?
     
    Dstraktd likes this.
  2. mystic chips

    mystic chips Active Forum Member

    Joined:
    Sep 14, 2016
    Messages:
    34
    Likes Received:
    42
    I think it's the first problem, but I'm not sure why it's been happening in recent weeks. I got that message 3-4 times in a half hour period a week ago, so that night I just muted everyone on my side to be able to play and had no issues after. I unmuted everyone the next day, but haven't had it in the last few days even with a full server. So I have no idea what really causes it.
     
    Dstraktd likes this.
  3. Gary Busey

    Gary Busey Administrator Staff Member

    Joined:
    Sep 8, 2016
    Messages:
    190
    Likes Received:
    424
    It's your rate setting. Open console, and type "rate 80000".
     
    Dstraktd likes this.
  4. Dr. Thor

    Dr. Thor One hammer Two hammer Three hammer THOR!

    Joined:
    Sep 16, 2016
    Messages:
    676
    Likes Received:
    961
    I have this issue as well, it seems to happen when more than ~6 people are talking on the mic at once. I added -rate 80000 to my launch options. I hope that works. Thanks Gary.
     
    Dstraktd likes this.
  5. PongQ

    PongQ Well-Known Forum Member

    Joined:
    Sep 28, 2016
    Messages:
    516
    Likes Received:
    903
    You can add/modify: rate "80000"
    to <drive>\SteamLibrary\steamapps\common\Team Fortress 2\tf\cfg\config.cfg

    The number is flexible. I've used 60000 for some time and haven't had the buffer overflow error since.
     
    Dstraktd likes this.

Share This Page